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Agisoft MetaShape Guide for SfM with GCPs
Agisoft MetaShape Guide for Structure from Motion (SfM) with GNSS-georeferenced Ground Control Points (GCPs)
Sean Gallen (Colorado State University) adapted from resources from Sharon Bywater-Reyes (Northern Colorado University), Beth Pratt-Situla (EarthScope), and Dan McGrath (Colorado State University).
Learning objectives:
By the end of this activity, students will be able to…
· Load and process uncrewed aerial vehicle (UAV) photos in MetaShape.
· Align and quality control photos.
· Input ground control point (GCP) coordinates.
· Generate 3D point cloud and secondary products.

The activity uses Agisoft MetaShape Pro, a licensed software. 30-day free trials of the software are available, as are educational pricing.
This activity will take you through a workflow to generate an SfM model with GCPs. Below is a diagram that shows the basic workflow, providing a high-level overview of what you are about to do. Step-by-step instructions follow. 
Basic SfM with GPCs workflow:
[image: A diagram of the SfM-GCP workflow
1. Add photos
2. Check Ref panel
3. Align photos
4. Error reduction
5. Load GCPs
6. Link GCPs and targets in photos
7. Optimize camera alignment
8. Build dense point cloud
9. Bould DEM
10. Build orthomosaic]


1. [image: A screenshot of a computer
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Optional: You can process the SfM model faster if you use Graphics Processing Units (GPUs) rather than Central Processing Units (CPUs) if you have the option to do so. This is not required, but it can help with large processing jobs. CPUs are the default, but you can change this by opening Agisoft MetaShape and going to Tools > Preferences (on Mac MetaShapePro > Preferences. A window will open, select “GPU”, the second tab. Check all available GPUs (some computers will have more than one) and in the bottom left, uncheck “Use CPU when performing GPU processing. Note: this step is not required.
2. Add Photos
Workflow menu > Add Photos.
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· A new window will appear. Navigate to the folder containing your photos and select the images you want to use. Once all the photos are selected, click the Open button.
· If prompted, select the data layout as Single Cameras.
· Click on the Reference tab at the bottom of the Reference Pane window. If this option isn’t available, go to View > Reference.
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3. Check the Coordinate System in the Reference Panel
· In the Reference Panel window, select the Tools button, [image: ], in the top right of the panel. 
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· Confirm or change the coordinate system to WGS84 (EPSG: 4326).
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· Click OK when you are done.

4. Align Photos
· The first step to generating an SfM model is to align the photos. This will generate what is called a sparse point cloud (also called “tie points”) and initial camera locations.
· Under the Workflow menu, select Align Photos. A new window will open.
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· Under “General”, check Generic preselection and Reference preselection. In the dropdown tabs to the right, select Medium for Accuracy (the top option) and Source for the bottom option.
· Under “Advanced”, check Adaptive camera model fitting. For the Key point limit, use 40,000, and for the Tie point limit, use 4,000.
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· Click OK when you have confirmed these settings.
(If you get the message “Found oblique cameras without specified capture distances. Continue?”, click Yes)
· This will take some time to run, depending on the number of photos you have and how powerful your computer is.
· Some of your photos might not align. This is okay. Simply acknowledge the prompt if it appears.
· Once the photo alignment is complete, switch back to the Workspace tab (located at the bottom left). Open the Chunk to visualize the tie points in the Model Window.
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· Save your project and file using the Save button in the main toolbar. Save the file to a location you can easily find.
· You can turn on and off the image locations by selecting Model > Show/Hide Items > Show Cameras.
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· You can change the perspective of the sparse point cloud model by clicking the sphere in the middle of the model and moving it around.

5. Error Reduction and Bundle Adjustment
Reducing errors in your sparse point cloud is important in producing a high-quality SfM model. In this step, you will remove points with high uncertainty to improve the resulting final model products. We will do this by using threshold values for “acceptable error”.
The thresholds provided here are guidelines or suggestions and therefore may not apply to your specific project. The primary goal of this step is to remove problematic points that have high uncertainty, without removing too many points. It is acceptable if ~40-50% of the points are removed, but this will not always be the case.
· Select Tools > Tie Points > Clean Tie Points. Then under the Criterion dropdown, select Reconstruction Uncertainty. Drag the bar down to 16–20. You will start to see some points turn pink. Press Delete then OK.
· Select Optimize Camera Alignment. This is the Magic Wand or Star, [image: ], button on the Reference Panel window.
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· A new Optimize Camera Alignment window will open. In this window, under “General” check on Fit f; Fit k1; Fit k2; Fit k3; Fit cx, cy; Fit p1; Fit p2; Fit b1; Fit b2. 
Uncheck Fit k4. Under “Advanced” Uncheck - Adaptive Camera model fitting, Estimate tie point covariance, Fit additional corrections. See also screenshot for reference. 
· Select Tools > Tie Points > Clean Tie Points. Then under the Criterion dropdown, select Projection Accuracy. Drag the bar down to ~10. You will start to see some points turn pink. Press Delete then OK.
[image: A screenshot of a computer

AI-generated content may be incorrect.]
· Select Optimize Camera Alignment. This is the Magic Wand or Star, [image: ], button on the Reference Panel window.
A new Optimize Camera Alignment window will open. Check the same boxes as above.
· Select Tools > Tie Points > Clean Tie Points. Then under the Criterion dropdown, select Reprojection Error. Drag the bar down to ~0.25. You will start to see some points turn pink. Press Delete then OK.
· Select Optimize Camera Alignment. This is the Magic Wand or Star, [image: ], button on the Reference Panel window.
A new Optimize Camera Alignment window will open. Check the same boxes as above.


6. Load Ground Control Points (GCPs)
Your ground control points should be in a text/ascii file. Typically, these are comma-delimited file (csv) or tab-delimited (.txt, .tsv) with Longitude, Latitude, and Elevation/Altitude columns. The instructions below assume a .csv file.
[image: ]Note: GCP elevations obtained from a GPS/GNSS survey instrument will typically be given in ellipsoid height. However, the elevations provided by some UAV instruments may be given in orthometric height. If you wish to have the GCP elevations in orthometric height, you will have to convert your ellipsoid elevations with reference to a geoid model. This can be done using: EarthScope’s Geoid Height Calculator, where you can also read more about this topic.
· Choose from the Reference window, select the Import Reference icon, and select your csv file with the GCPs. A new window will open.





· [image: A screenshot of a computer

AI-generated content may be incorrect.]Make sure the Longitude, Latitude, and Elevation/Altitude columns are correctly aligned under the MetaShape column headers. If they are not, you will need to order them manually at this step. If your .csv file as a header row, it may be more convenient to “Start import at row 2”.
· Once you make sure everything is correctly entered, select OK and select Yes to All to create new markers.
· Go to the Reference window and select all images (cameras, not markers).
· Uncheck box one, and all green checks should disappear. This is a critical step because you are overriding the 1-5 meter accuracy of the UAV internal GPS with the decimeter-scale accuracy of the GCPs.
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7. Link GPC points to Targets in photos.
· Right-click on your first marker and choose Filter Photos by Markers. On the bottom of the screen, select the Photos tab. If no photos are showing in the Photos tab, try right-clicking on the marker in the Model pane and selecting Filter Photos by Point instead. (note: if no photos are showing up after Filtering by Markers
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· Zoom into the first image to find the white flag. Click and drag the white flag to the center of the GCP target in the photo. Depending on the GCP you choose it might be offset. The flag marker should not turn green. Make sure to zoom in enough to place the flag at the center of the target. Do this for about 8 photos for this Marker.
[image: ]
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· Repeat this process for the second Marker.
8. Optimize Camera Alignment (and link remaining GCPs)
· Run Optimize Camera Alignment (the Star or Magic Wand button on the Reference Window). This will improve the estimated position of the remaining Markers and their associated GCP targets.
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· Repeat this process for all the remaining markers. 
· Once completed, run Optimize Camera Alignment one more time.
9. Build Dense Point Cloud
· With the photo alignment optimized, errors reduced, and tied to the GCPs, we are ready to generate our SfM models. The first step in this process is building a dense point cloud.
· Under the Workflow tab, select Build Point Cloud. A new window will open.
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· There are options in this window for the Quality of the model desired and Depth filtering.
· [image: A screenshot of a computer

AI-generated content may be incorrect.]Quality – The higher the quality, the longer the processing time. Select your desired quality. Most often, this will be High, but for faster processing, Medium might be appropriate for a class project.
· Depth filtering – Depth filtering (under the Advanced tab) determines how depth is calculated in the SfM model. Mild maintains small details in the model while Aggressive smooths things, assuming these details are not important for your application. Most studies use Mild.
· Click OK and let the Dense Point Cloud be built. This will take some time.
· Once complete, look at the dense point cloud. Make sure the Model pane is showing. Then go to Model  > View Mode > Point Cloud > Point Cloud - Colors. 
(Point Cloud – Elevation may also be an interesting view)
[image: A screenshot of a computer

AI-generated content may be incorrect.]

By original photo color				By elevation
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· Optional: If you want to classify your point cloud points, you can do so by selecting Tools > Point Cloud > Classify Ground Points. This will allow you to classify points as things like roads or vegetation or bedrock. Once classified, you can visualize the results via Tools > Dense Point Cloud > Filter by Class and deselecting all classes other than Ground. For this activity, we will not use this option.
[image: ]

10. Build a Digital Elevation Model (DEM)
· Once the Dense Point Cloud is generated, we can use it to build a DEM. 
· Under the Workflow tab, select Build DEM. A new window will open.
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· [image: A screenshot of a computer

AI-generated content may be incorrect.]For now, Disable Interpolation to reduce any interpolation artifacts from the DEM, but you may choose to enable this feature depending on your application.
· Click OK, and your DEM will begin processing.
· Once it is completed, you can export your DEM as a geotiff that can be imported into GIS software like ArcPro or QGIS. To do this, select File > Export > Export DEM. Then select “TIFF/GeoTIFF (*.tif)”. You can also export it as a .kmz file for Google Earth or a variety of other formats.
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· If you want to view what the DEM looks like, go to the Workspace pane (instead of Reference pane) > select the down-arrow next to Chunk and then double click DEM.
[image: A screenshot of a computer
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11. Building an Orthomosaic
· An orthomosaic is an image that stitches together your photos. It is useful for visualization and can be used for remote sensing. In MetaShape, you can produce one that is georeferenced.
· [image: A screenshot of a computer

AI-generated content may be incorrect.]Under the Workflow tab, select Build Orthomosaic. A new window will open.
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· Select the DEM as the surface, if it isn’t already selected.
· Select Resolution, choose the Metres button below Pixel size. Input your desired resolution in meters. If you are unsure, a value of 0.01 to 0.10 m should be good. Enable hole filling should most likely be checked.
· Select OK to process your Orthomosaic.
· Once the Orthomosaic is finished processing, you can export it as a geotiff or view it, following similar procedures as above for the DEM.

12. Save your Agisoft project
Questions or comments please contact education@earthscope.org. Version Sept 5, 2025.	Page 1
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