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Type of Activity: Computer-based problem set

Brief description: Students learn how to use the autocorrelation function in NIH-Image to quantify shape-preferred
orientations.  Students develop understanding of what the autocorrelation function does by using synthetic images
and then apply this knowledge to real rocks.

Context
Type and level of course: Undergraduate structural geology course; typically juniors and seniors.

Skills and concepts needed for the activity: Students should be comfortable using spreadsheets to organize,
manipulate, and graph data; basic understanding of shape-preferred orientation in rocks (e.g. foliation).

How the activity is situated in my course: Designed to be completed in a four-hour laboratory period.  However,
students are given a week to complete the activity.

Goals of the Activity
1. Learn how to use NIH-Image to quantify shape-preferred orientations in images.

2. Discover how autocorrelation images vary with aspect ratio of particles and the amount of preferred
orientation (fabric intensity).

3. Apply this understanding to rocks.

Higher order skills:  Collecting and manipulating real data; making decisions on what the data mean.

Other skills:  Making figures, writing figure captions, presenting data and interpretations in narrative form.

Description
This activity can be completed individually or in small groups.  The first part of the activity focuses on exploration
and discovery of how autocorrelation function (ACF) images correspond to real images.  The students are given six
synthetic images with particles of known aspect ratio and shape preferred orientation.  They follow a detailed recipe
for generating ACF’s, construct a figure comparing images and ACF’s, and are asked to write a short narrative
describing the qualitative relationship between an image and ACF shape.  The students then learn how to measure
the ellipticity of ACF contours and plot these data to discover the relationship between shape preferred orientation
and ACF ellipticity.  After completing the discovery part of the activity, the students apply this knowledge to images
of thin sections from the Quottoon pluton near Prince Rupert, British Columbia.  In addition, they learn how to
measure ACF grain size and plot these data and ACF ellipticity as a function of distance from the Coast shear zone,
a major oblique-slip shear zone that defines the western border of the Quottoon pluton.  Finally, the students are
asked to discuss the relationship between shape preferred orientation, ACF grain size, and the Coast shear zone.

Evaluation
The students construct and hand in three figures, complete with figure captions.  For each figure, they write a short
narrative describing and interpreting the figure.
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Documentation
This document contains the handout for students and Figures 1-3 of the solution set.  Go to the Teaching Structural
Geology Resource Collection for the entire set of materials for this activity:

1. Handout for the students.  This document provides a brief introduction to the activity including a goals
statement, detailed step-by-step instructions on how to calculate the ACF, and open-ended questions for the
students to answer.

2. Synthetic images.  There are six grayscale synthetic images saved as pict files in a folder labeled
“SynImages”.  These can be opened directly in NIH-Image, or any other program that reads pict files.

3. BC Images.  These are grayscale pict files of thin section scans from nine samples of the Quottoon pluton
at various distances from the Coast shear zone.  Included in the folder labeled “BC Images” is a word
document called “Image Notes” that gives the distance of each sample from the western contact of the
Coast shear zone.

4. Solution Set.  Excel document with solutions and graphs.
5. Solution Figures. Figures 1-3 saved as Adobe Illustrator files.
6. Thin section scans.  Color scans of entire thin sections for each of the samples are given in the folder

labeled “ThinSectionScans”.  See Instructor’s notes for details on how these are acquired and manipulated
to generate the images used in “BC Images.”

(URL: http://serc.carleton.edu/NAGTWorkshops/structure04/resources.html)

Instructor’s Notes
General Comments

a. I begin the exercise by engaging the students in a conversation about shape-preferred orientations in rocks.
I ask them to give me examples from their own experience (e.g. field trips) and/or previous course work
and reading.  You can also show some examples of non-foliated and foliated rocks and ask how they might
describe differences in foliation intensity.  That is, what do we mean when we say a rock is well-foliated?
What is our brain doing to make this observation?

b. I also like to point out that humans are very good at picking out patterns in nature, like subtle variations in
foliation intensity, but that we are not that good at quantifying these patterns.  This is where something like
the autocorrelation function can help us.  That is, we can assign numbers to patterns like shape-preferred
orientations in rocks and therefore have the ability to quantify differences in these patterns.

Types of Images

c. The autocorrelation function works on almost any image that shows a preferred orientation; from the shape-
preferred orientation of biotite in thin section to lineaments on images from Mars or Venus. The only
requirement is that the image must be square.  I typically use images with pixel dimensions of 512 x 512, or
1024 x 1024.  Cropping images to these pixel dimensions can be done in most image-manipulation
programs like Adobe Photoshop.

d. Scanning thin sections.  If you have access to a slide scanner, you can use an old plastic slide casing and
tape, to mount your thin section.  Scan with a minimum pixel dimension of 1024 in the short direction.  I
usually use 2000 x 1400 pixels.  This allows you to crop the image where you want and to make a good
quality 8” x 10” print.  Scanning rock slabs on a flatbed scanner should also yield good results.
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Geology 265: Structures Carleton College

Lab#6:  Using the autocorrelation function in NIH-Image to determine shape-preferred
orientations.

Introduction
Thanks to natural selection, humans are very good at picking out subtle differences in texture, grain size, and
particle orientation in rocks.  However, we are not very good at quantifying these differences other than saying a
rock is well-foliated or not.  In this exercise you will learn how to use the autocorrelation function (Panozzo
Heilbronner, 1992) to quantify the shape-preferred orientation in rocks.

Goals
1. Learn how to use NIH-Image to quantify shape-preferred orientations in images.
2. Discover how autocorrelation images vary with aspect ratio of particles and the amount of preferred

orientation (fabric intensity).
3. Apply this understanding to rocks

NIH-Image
NIH-Image is a freeware image analysis program developed and maintained by the U.S. National Institute of Health
and can be run on Mac and PC platforms. This exercise was developed using the Mac version of the program.  (The
Mac version is not OS X native, but runs fine in OS 9.2 emulation mode.) The most recent version of the program
can be downloaded from the following site:  http://rsb.info.nih.gov/nih-image.

Exploration
To help develop your intuition, we will calculate the ACF for a series of synthetic images with known particle
shapes and aspect ratios.  Then we will apply the ACF to real rocks.

1. Start NIH-Image.  From the Special menu, choose Load Macros.  Find the Macros folder in the NIH-Image
folder and select FFT Macros.

2. From the folder labeled “SynImages”, open image file “SynImage1.pct”.  Closely examine the image by
dragging it around using the hand tool.

3. From the Special menu, select Autocorrelation.  (If you get an error, try increasing the memory allocation of
NIH-Image to 2000 K or higher.)  A new window labeled “Autocorrelation” is generated, and after a few
seconds of calculation by the macro, the ACF of your image should appear on your desktop.  To see the shape
of the ACF better, go to the Options menu and select 8 Grays from Color Tables.  The 8 gray levels clearly
show the contours of the ACF (similar to a topographic map). To better understand the geometry of the ACF, go
back to the color tables (Options menu) and select Rainbow.  From the Analyze menu, select Surface Plot.  In
the dialog box, set the dimensions to 512 x 512 and check the wire frame and grayscale/color boxes.  Click OK.
Note that the warm colors correspond to the higher elevations of your ACF.  Go ahead and try this with 8 grays
as well.  When you’re done playing, save the 2-dimensional ACF image with 8 grays using an appropriate
name.

4. Now, calculate the ACF for the remaining synthetic images (1-6), and save as in step 3.

5. Once you have all six ACF’s calculated and saved, make a figure (call it Figure 1) that shows the synthetic
images and their corresponding ACF’s.  [Because you have six images, they should be labeled A), B), C), …]
Remember, all figures have captions.  Typically, you don’t need the entire ACF image to describe the shape-
preferred orientation.  Therefore, when making your figure, only copy the middle of the ACF.  To do this, from
the Special menu, select Create 512 x 512 Selection, and then copy and paste in the drawing program you are
using to construct Figure 1.
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Stop here.  Briefly answer the following questions by referring to Figure 1:

a. What is the relationship between shape preferred orientation and the shape of the ACF?
b. What is the relationship between the shape and aspect ratio of the rectangles in your

image, and the shape of the ACF?

6. Our next goal is to quantify the shape preferred orientation.  Open the ACF image for SynImage1. Make sure
the “Info” window is visible (From the Window menu, select Info).  From the Options menu, select Density
Slice (or double click on the density slice tool in the tool bar).  Note that a red line or box appears in the LUT
window and on the ACF image.  Move the cursor to the LUT window; click above the red line and hold the
mouse button down.  Drag the mouse up and down and note how the red area on the ACF image grows and
shrinks.  You can click above and below the red area to set the bounds, and within the red area to slide the
selected (red) area up and down.  Go ahead and play. The area highlighted in red corresponds to the area
between the contour intervals shown in the Info window.  The upper and lower bounds shown in the Info
window vary between 1-256, where 1 corresponds to the lowest (farthest outside) contour and 256 to the highest
contour (exactly in the middle of the ACF image).  (Actually, the bounds vary between 1-254 in the Info
window because 2 levels are reserved for black and white.)

7. Now, let’s get to business.  Set the lower bound of the density slice to 32 and the upper bound to 64.  (Again,
click and drag in the LUT window while watching the Info window to set the bounds).  Note that the upper and
lower bounds of the density slice corresponds to the two outer (low elevation) contours in your 8 grays image.
Select the wand tool from the tool bar and click outside the red area near the 32nd contour of the ACF image.
The 32nd contour should be highlighted at this point.  From the Edit menu, select Copy, then from the File menu,
select New.  Create a 500 (width) x 600 (height) image.  From the Edit menu, select Paste, and drag the pasted
image to near the top of your newly created image window.   From the Edit menu, select Fill.  You now have an
elliptical object filled with black that can be thought of as a horizontal slice through the ACF image at the 32nd

contour.

8. Return to your ACF image and use the wand tool to select the 64th contour by clicking near the inside of your
density slice.  Copy, paste, drag, and fill as you did in step 7.  Return to your ACF image, and click in the
middle of your density slice in the LUT window, and drag the slice so that the lower and upper bounds
correspond to the 96th and 128th contours.  Copy, paste, drag, and fill as above, and repeat for the 160th and 192nd

contours.

9. Now you have an image with six slices corresponding to the 32nd, 64th, 96th, 128th, 160th, and 192nd contours.
Save this image with an appropriate name.  From the Analyze menu, select Options.  The dialog box contains
different parameters that can be measured in an image. For our purposes, select Ellipse Major Axis, Ellipse
Minor Axis, and Angle.  This will calculate the best fit ellipse to each of the objects in your image and give the
angle of the major axis with respect to horizontal. Click OK to set these options.

10. From the Analyze menu, select Analyze Particles.  Check Label Particles and Reset Measurement Counter in
the dialog box.  Click OK.  Note that the slices are now labeled with numbers. From the Analyze menu, select
Show Results.  A dialog box appears showing the measurements of the selections you made in Step 9.  The
units for the major and minor axes are in pixels. From the Edit menu, select Copy measurements, and paste into
a spreadsheet program like Excel.

11. Do steps 6-10 for all six of the synthetic images, saving your data to a spreadsheet.  Once you have all the data
organized (and labeled!), calculate the ellipticity (major axis/minor axis) of the best fit ellipse for each of the
contours and make the following two graphs:

A) ACF ellipticity vs. Contour for synthetic images 1-4.

B) ACF ellipticity vs. Contour for synthetic images 4, 5 and 6.
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Use a scatter plot for each of the graphs and be sure to label the resulting curves.  Call these two graphs Figure 2
(A&B).

Stop here.  Referring to Figure 2, write a brief paragraph describing the quantitative relationship
between aspect ratio of the rectangles, ACF ellipticity, and shape preferred orientation. Note that Table 1
contains important information about the synthetic images.

Application: The Quottoon pluton, British Columbia
The Quottoon pluton is a Late Cretaceous foliated biotite hornblende tonalite that intruded during dextral oblique
east side up motion along the Coast shear zone near Prince Rupert, British Columbia (Ingram and Hutton, 1994;
Klepeis et al., 1998, Andronicos et al., 1999).  The foliation, defined by the shape-preferred orientation of biotite and
hornblende, increases in intensity toward the Coast shear zone (Fig. 1).  In order to help quantify this change in
foliation intensity, we will use the autocorrelation function to calculate the ellipticity of the ACF as a function of
distance from the Coast shear zone.  Important: we will only use the 96th contour for this particular application.
(Why the 96th contour?  This is a rhetorical question.)  We will also use the 96th contour to calculate the ACF grain
size.  The ACF grain size is defined as:

ACF grain size (mm) = major!axis*minor!axis          with the axes given in mm.

The relationship between the ACF grain size and the grain sizes observed in thin section is not straightforward.
However, it is clear that as the average grain size in thin section increases, the ACF grain size increases.  Therefore,
useful information might be gleaned from comparing the ACF grain sizes between samples (e.g. Davidson et al.,
1996).

12. To calculate the ACF grain size, we need to set the scale of the images in NIH-Image.  For this example, the
scale of the images is 41 pixels/mm.  (Note that when comparing the ACF between samples, the scale of your
scanned images should be the same.)  You don’t need to set the scale until you are ready to measure the
contours of your ACF.  Therefore, calculate the ACF for each of the eight images provided in the folder labeled
BC Images.  Use the density slice tool to select the 96th contour and copy and paste this contour to a separate
image file, and fill as you did in step 7.

13. Save the image file with the 96th contours and be sure to keep track of sample numbers.  To set the scale of this
image, from the Analyze menu, select Set Scale.  In the dialog box, select millimeters from the units pop-up
menu, and type 41 in the scale box corresponding to 41 mm/pixel, the scale of these images.  Click OK to set
the scale.

14. Now calculate the major and minor axes of the best fit ellipse using Analyze particles from the analyze menu
and copy the results to a spreadsheet.  Calculate the ellipticity and ACF grain size using the equation above.  On
the same graph, plot ACF ellipticity and ACF grain size (y-axis) vs. distance from the western contact of the
Quottoon pluton (see Quottoon image notes for distances).  Call this Figure 3.

Referring to Figure 3 and the original images, comment on the how the fabric in the Quottoon pluton
changes from east to west.
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Table 1. Notes for SynImages 1-6.

Image Shape Preferred Orientation Rectangle Aspect Ratio

SynImage1 No preferred orientation1 3:1

SynImage2 40% shortening2 3:1

SynImage3 60% shortening2 3:1

SynImage4 Perfect3 3:1

SynImage5 Perfect3 2:1

SynImage6 Perfect3 5:1
1 Eighteen rectangles oriented every 10° between 0° and 180°.
2 Eighteen lines oriented every 10° between 0° and 180°, followed by shortening (pure shear; lf/lo) by amount given.
Rectangles then aligned with deformed lines.  Line oriented parallel to the shortening direction was not used in these
images.
3 Rectangles oriented with long axis horizontal.
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Figure 1.  Geologic map of the Quottoon pluton near Prince Rupert, British Columbia.  Filled 
circles show the locations of the samples used in this exercise.  Highway 16 (dash-dot line) 
shown for reference.  Note that deformation associated with the Coast shear zone affects a much 
wider area than shown by the dashed line.
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Figure 1. Synthetic images and associated ACF images.  (A) SynImage1: no preferred orientation; 
rectangles with 3:1 aspect ratio.  (B) SynImage2: shape-preferred orientation (SPO) after 40% 
shortening; rectangles with 3:1 aspect ratio. (C) SynImage3: SPO after 60% shortening; rectangles with 
3:1 aspect ratio. (D) SynImage4: perfect SPO; rectangles with 3:1 aspect ratio. (E) SynImage5: perfect 
SPO; rectangles with 2:1 aspect ratio. (F) SynImage6: perfect SPO; rectangles with 5:1 aspect ratio.
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Figure 2. (A) ACF ellipticity vs. contour for synthetic images 1-4.  The aspect ratio of the rectangular 
particles in each image is 3:1.  Squares = SynImage 1, perfect shape-preferred orientation (SPO); 
diamonds = SynImage 2, SPO after 60% shortening (lf/lo); circles = SynImage 3, SPO after 40% 
shortening; triangles = SynImage 4, no preferred orientation. (B)  ACF ellipticity vs. contour for 
synthetic images 1, 5, 6.  These images have perfect SPO's with particles of different aspect ratios.
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Figure 3.  ACF ellipticity (circles) and grain size (triangles) vs. distance from the western contact of the 
Quottoon pluton.
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